summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2012-10-27 01:11:13 +0000
committerDmitry V. Levin <ldv@altlinux.org>2012-10-27 01:13:53 +0000
commit17e3860ee8684b397b99eea59b6458a8a7b88f5c (patch)
treed36e98feb494a4776361bb9bd00bc905d38dc9cc /Makefile.am
parent7943966f6cd137e44f27d56aaf21b023fb1fae63 (diff)
downloadstrace-17e3860ee8684b397b99eea59b6458a8a7b88f5c.tar.gz
strace-17e3860ee8684b397b99eea59b6458a8a7b88f5c.tar.bz2
strace-17e3860ee8684b397b99eea59b6458a8a7b88f5c.tar.xz
Filter out redundant "*32" ioctl entries
* linux/ioctlent-filter.awk: New file. * Makefile.am: Use it. * linux/ioctlent.h.in: Removed redundant "*32" entries.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3e8c810..aa1a5f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -151,4 +151,5 @@ $(ioctlent_h): $(top_builddir)/config.status $(ioctlent_h_deps)
$(MKDIR_P) $(builddir)/$(OS)
cat $(ioctlent_h_deps) | \
$(COMPILE) -E -P - | \
- LC_ALL=C sort -u -k3,3 -k2,2 > $@
+ LC_ALL=C sort -u -k3,3 -k2,2 | \
+ awk -f $(srcdir)/linux/ioctlent-filter.awk > $@