summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGrant Edwards <grant.b.edwards@gmail.com>2011-04-07 20:25:40 +0000
committerDmitry V. Levin <ldv@altlinux.org>2011-04-08 20:47:56 +0000
commit8a08277d13d0378c2ff3ce851534c3bf7e31defa (patch)
tree3bf9bb239f86ccde9b8b285fc7683def48943ff3 /Makefile.am
parent4cee0af77b0275740f7f97ae5d778f60d5ac7f88 (diff)
downloadstrace-8a08277d13d0378c2ff3ce851534c3bf7e31defa.tar.gz
strace-8a08277d13d0378c2ff3ce851534c3bf7e31defa.tar.bz2
strace-8a08277d13d0378c2ff3ce851534c3bf7e31defa.tar.xz
Add ability to print file descriptor paths and filter by those paths
* pathtrace.c: New file, implements matching syscall arguments to user-specified file paths. * Makefile.am (strace_SOURCES): Add pathtrace.c. * defs.h (TCB_FILTERED, filtered): New defines. (getfdpath, pathtrace_select, pathtrace_match, show_fd_path, tracing_paths): New declarations. * strace.c (show_fd_path, tracing_paths): New global variables. (usage, main): Implement handling of -y and -P options. * strace.1: Add descriptions of -y and -P options. * syscall.c (trace_syscall_entering): Add path matching logic to the print/noprint decision and set the TCB_FILTERED bit appropriately. (trace_syscall_exiting): Use filtered() macro that checks the TCB_FILTERED bit to determine print/noprint status. * util.c (printfd): Use getfdpath().
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ba19a7d..8134b0d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,7 +18,7 @@ AM_CPPFLAGS = -I$(srcdir)/$(OS)/$(ARCH) -I$(srcdir)/$(OS) -I$(builddir)/$(OS)
strace_SOURCES = strace.c syscall.c count.c util.c desc.c file.c ipc.c \
io.c ioctl.c mem.c net.c process.c bjm.c quota.c \
resource.c signal.c sock.c system.c term.c time.c \
- proc.c scsi.c stream.c block.c
+ proc.c scsi.c stream.c block.c pathtrace.c
noinst_HEADERS = defs.h
EXTRA_DIST = $(man_MANS) errnoent.sh signalent.sh syscallent.sh ioctlsort.c \