summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <vda.linux@googlemail.com>2012-02-25 15:19:02 +0100
committerDenys Vlasenko <vda.linux@googlemail.com>2012-02-25 15:19:02 +0100
commitaa925db23634fe6a2c1d4b47accb3649daf1b781 (patch)
tree0215b77bd1fbf4d5d40a0da16ab9fb0982e74f1f /Makefile.am
parent1a3cf10c3095a9f80138b83f3d54499b825c9797 (diff)
downloadstrace-aa925db23634fe6a2c1d4b47accb3649daf1b781.tar.gz
strace-aa925db23634fe6a2c1d4b47accb3649daf1b781.tar.bz2
strace-aa925db23634fe6a2c1d4b47accb3649daf1b781.tar.xz
Remove a few more code parts which are unused on Linux
This change is abapted from Dmitry's changes to remove support for non-Linux architectures. * Makefile.am: Remove if LINUX/endif pairs. * defs.h: Remove stream_ioctl() declaration. * ioctl.c (ioctl_decode): Remove 'ifdef HAVE_SYS_STREAM_H' block. * resource.c: Use 'defined(FOO)' instead of 'defined FOO' form. * util.c: Likewise. * signal.c: Remove conditional includes which are never used on Linux. * stream.c: Likewise. * file.c: Remove excessive empty lines. Signed-off-by: Dmitry V. Levin <ldv@altlinux.org> Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 0 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index d9c4795..97cd43b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -118,8 +118,6 @@ $(srcdir)/CREDITS: $(top_srcdir)/CREDITS.in $(top_srcdir)/.mailmap \
export TAR_OPTIONS = --owner=0 --group=0 --numeric-owner --mode=go-w,go+rX
-if LINUX
-
IOCTLDIR = /usr/include
IOCTLASM = asm
@@ -137,9 +135,6 @@ ioctls.h: $(srcdir)/linux/ioctlent.sh
ioctldefs.h: ioctls.h ;
endif
-endif
-
-if LINUX
ioctlent_h = $(builddir)/$(OS)/ioctlent.h
BUILT_SOURCES += $(ioctlent_h)
@@ -150,5 +145,3 @@ $(ioctlent_h): $(top_builddir)/config.status $(ioctlent_h_deps)
cat $(ioctlent_h_deps) | \
$(COMPILE) -E -P - | \
LC_ALL=C sort -u -k3,3 -k2,2 > $@
-
-endif