summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-17 22:19:31 -0400
committerDmitry V. Levin <ldv@altlinux.org>2012-04-18 15:27:25 +0000
commitebee04cfb009bdc46599774b4647f6615b6ce3a2 (patch)
treec2eef690822087a0e83361585ebd95fbdfeeb406 /Makefile.am
parent085e42886052190d3e515ca865546b527f59cdd1 (diff)
downloadstrace-ebee04cfb009bdc46599774b4647f6615b6ce3a2.tar.gz
strace-ebee04cfb009bdc46599774b4647f6615b6ce3a2.tar.bz2
strace-ebee04cfb009bdc46599774b4647f6615b6ce3a2.tar.xz
Decode /dev/loop ioctls
Needed to debug some losetup failures, and it's easier when you can see what the kernel is getting vs what you think you're sending, so add some decoders for those ioctls. * loop.c: New file. * Makefile.am (strace_SOURCES): Add loop.c. * defs.h (loop_ioctl): New prototype. (string_quote): Likewise. * ioctl.c (ioctl_decode): Call loop_ioctl when code is 'L'. * util.c (string_quote): Remove static keyword. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e9393d8..3e8c810 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,8 @@ AM_CPPFLAGS = -I$(srcdir)/$(OS)/$(ARCH) -I$(srcdir)/$(OS) -I$(builddir)/$(OS)
strace_SOURCES = strace.c syscall.c count.c util.c desc.c file.c ipc.c \
io.c ioctl.c mem.c net.c process.c bjm.c quota.c \
resource.c signal.c sock.c system.c term.c time.c \
- scsi.c stream.c block.c pathtrace.c mtd.c vsprintf.c
+ scsi.c stream.c block.c pathtrace.c mtd.c vsprintf.c \
+ loop.c
noinst_HEADERS = defs.h
EXTRA_DIST = $(man_MANS) errnoent.sh signalent.sh syscallent.sh ioctlsort.c \