summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2011-03-15 17:19:09 +0000
committerDmitry V. Levin <ldv@altlinux.org>2011-03-15 17:19:09 +0000
commit03aefdadb20f3bdd05bf644dc2ce1e85758a5aee (patch)
treecdcb7b379d5c6a173f13f4e36f36d0eda070a014 /configure.ac
parent4e4fcafe9edc87b2f99193287267783ddc856883 (diff)
downloadstrace-9acee40e957572235257707eff006410cc1e0df3.tar.gz
strace-9acee40e957572235257707eff006410cc1e0df3.tar.bz2
strace-9acee40e957572235257707eff006410cc1e0df3.tar.xz
Ensure that PTRACE_GETSIGINFO et al are always defined on Linuxv4.6
* configure.ac (AC_CHECK_DECLS): Add PTRACE_* constants. * defs.h [LINUX]: Define those PTRACE_* constants that are not provided by <sys/ptrace.h>.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c14c011..402f088 100644
--- a/configure.ac
+++ b/configure.ac
@@ -306,6 +306,16 @@ AC_CHECK_MEMBERS([struct sigcontext.sc_hi2],,, [#include <signal.h>
AC_CHECK_DECLS([sys_errlist])
AC_CHECK_DECLS([sys_siglist, _sys_siglist],,, [#include <signal.h>])
+AC_CHECK_DECLS([\
+ PTRACE_SETOPTIONS, \
+ PTRACE_GETEVENTMSG, \
+ PTRACE_GETSIGINFO, \
+ PTRACE_O_TRACEFORK, \
+ PTRACE_O_TRACEVFORK, \
+ PTRACE_O_TRACECLONE, \
+ PTRACE_EVENT_FORK, \
+ PTRACE_EVENT_VFORK, \
+ PTRACE_EVENT_CLONE],,, [#include <sys/ptrace.h>])
AC_PATH_PROG([PERL], [perl])