summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2007-08-03 09:59:09 +0000
committerRoland McGrath <roland@redhat.com>2007-08-03 09:59:09 +0000
commit75df90ee416be3e2196e0977cd405053df505073 (patch)
treeb05c5d9d82db148650b57504448c2d22f9dd2fc9 /debian
parent1dee3a81bd633d904d84ba5b328a62c11b616844 (diff)
downloadstrace-75df90ee416be3e2196e0977cd405053df505073.tar.gz
strace-75df90ee416be3e2196e0977cd405053df505073.tar.bz2
strace-75df90ee416be3e2196e0977cd405053df505073.tar.xz
2007-08-03 Roland McGrath <roland@redhat.com>
* debian/control (Build-Depends): Replace libc6-dev-s390x and libc6-dev-sparc64 with gcc-multilib. * debian/rules: Replace sparc-linux, s390-linux conditionals with general "arch64_map" hair, handle x86_64 and powerpc64 too. From Matthias Klose <doko@cs.tu-berlin.de>. Fixes Debian#435303.
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules24
2 files changed, 9 insertions, 17 deletions
diff --git a/debian/control b/debian/control
index b0a0aca..bc0a40c 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: utils
Priority: standard
Maintainer: Roland McGrath <frob@debian.org>
Uploaders: Wichert Akkerman <wakkerma@debian.org>, Frederik Schüler <fs@debian.org>
-Build-Depends: libc6-dev (>= 2.2.2-1) [!alpha !ia64], libc6.1-dev (>= 2.2.2-1) [alpha ia64], libc6-dev-s390x [s390], libc6-dev-sparc64 [sparc], debhelper (>= 5.0.0)
+Build-Depends: libc6-dev (>= 2.2.2-1) [!alpha !ia64], libc6.1-dev (>= 2.2.2-1) [alpha ia64], gcc-multilib [i386 powerpc s390 sparc], debhelper (>= 5.0.0)
Standards-Version: 3.7.2
Package: strace
diff --git a/debian/rules b/debian/rules
index 308e001..cc86e53 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,20 +10,12 @@ DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
VERSION := $(shell dpkg-parsechangelog | awk '/^Version: / { print $$2 }')
UDEB := strace-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb
-ifeq ($(DEB_HOST_GNU_TYPE),sparc-linux)
- build64 = yes
- HOST64 = sparc64-linux
+arch64_map = i386=x86_64 powerpc=powerpc64 sparc=sparc64 s390=s390x
+ifneq (,$(filter $(DEB_HOST_ARCH)=%, $(arch64_map)))
+ HOST64 = $(strip $(patsubst $(DEB_HOST_ARCH)=%, %, \
+ $(filter $(DEB_HOST_ARCH)=%, $(arch64_map))))-linux-gnu
CC64 = gcc -m64
-endif
-
-ifeq ($(DEB_HOST_GNU_TYPE),s390-linux)
- build64 = yes
- HOST64 = s390x-linux
- CC64 = gcc -m64
-endif
-
-ifeq ($(build64),yes)
- extra_build_targets += stamp-build64
+ extra_build_targets += stamp-build64
endif
ifeq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
@@ -32,7 +24,7 @@ else
CONFIG_OPTS = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
endif
-all build: stamp-build
+all build: stamp-build $(extra_build_targets)
stamp-%: %/Makefile
$(MAKE) -C $*
@@ -55,7 +47,7 @@ binary: binary-indep binary-arch
binary-indep:
-binary-arch: $(extra_build_targets) build checkroot
+binary-arch: build checkroot
test -f stamp-build || make $(MFLAGS) -f debian/rules build
-rm -rf debian/$(package) debian/files debian/substvars
@@ -91,7 +83,7 @@ binary-arch: $(extra_build_targets) build checkroot
debian/$(package)/usr/share/man/man1/strace.1
gzip -9 debian/$(package)/usr/share/man/man1/strace.1
-ifeq ($(build64),yes)
+ifneq (,$(HOST64))
install -o root -g root -m 755 build64/strace debian/$(package)/usr/bin/strace64
ln -s strace.1.gz debian/$(package)/usr/share/man/man1/strace64.1.gz
dh_strip