summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2014-06-27 02:51:21 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2014-06-27 02:51:21 +0000
commit2db3151eabc30fd6b5f168e793a4fde782ddb1da (patch)
treee0550933c09ad8c72020eade50b1165e5882b68e /tools/CMakeLists.txt
parent20e4c0d24e2dded15f99d7d658d679fd5b55cdc3 (diff)
downloadllvm-2db3151eabc30fd6b5f168e793a4fde782ddb1da.tar.gz
llvm-2db3151eabc30fd6b5f168e793a4fde782ddb1da.tar.bz2
llvm-2db3151eabc30fd6b5f168e793a4fde782ddb1da.tar.xz
Don't force the build of toos/lto as a static lib.
Any uses of tools/lto as a static lib should probably move to lib/LTO. This was also never implemented in the configure build, so this reduces the differences among the two. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@211852 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 13b7f5af85..846ad1e25d 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -49,7 +49,7 @@ add_llvm_tool_subdirectory(llvm-c-test)
add_llvm_tool_subdirectory(obj2yaml)
add_llvm_tool_subdirectory(yaml2obj)
-if( NOT CYGWIN )
+if(NOT CYGWIN AND LLVM_ENABLE_PIC)
add_llvm_tool_subdirectory(lto)
add_llvm_tool_subdirectory(llvm-lto)
else()