summaryrefslogtreecommitdiff
path: root/unittests/IR/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2013-01-07 15:35:46 +0000
committerChandler Carruth <chandlerc@gmail.com>2013-01-07 15:35:46 +0000
commitc779e96158cbac4c62df8e2053ab6a933eba5868 (patch)
tree0ec9e70170d75216c6f0ed5c994a0a0ba1fac2b3 /unittests/IR/CMakeLists.txt
parent3251e81d793a293b78f4914be6093b405c24fc2a (diff)
downloadllvm-c779e96158cbac4c62df8e2053ab6a933eba5868.tar.gz
llvm-c779e96158cbac4c62df8e2053ab6a933eba5868.tar.bz2
llvm-c779e96158cbac4c62df8e2053ab6a933eba5868.tar.xz
Rename the VMCore unittest tree to IR. Somehow was missed when doing the
library rename. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@171747 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/IR/CMakeLists.txt')
-rw-r--r--unittests/IR/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/unittests/IR/CMakeLists.txt b/unittests/IR/CMakeLists.txt
new file mode 100644
index 0000000000..4ff94f7035
--- /dev/null
+++ b/unittests/IR/CMakeLists.txt
@@ -0,0 +1,36 @@
+set(LLVM_LINK_COMPONENTS
+ asmparser
+ core
+ ipa
+ )
+
+set(IRSources
+ ConstantsTest.cpp
+ DominatorTreeTest.cpp
+ IRBuilderTest.cpp
+ InstructionsTest.cpp
+ MDBuilderTest.cpp
+ MetadataTest.cpp
+ PassManagerTest.cpp
+ TypeBuilderTest.cpp
+ TypesTest.cpp
+ ValueMapTest.cpp
+ VerifierTest.cpp
+ WaymarkTest.cpp
+ )
+
+# MSVC9 and 8 cannot compile ValueMapTest.cpp due to their bug.
+# See issue#331418 in Visual Studio.
+if(MSVC AND MSVC_VERSION LESS 1600)
+ list(REMOVE_ITEM IRSources ValueMapTest.cpp)
+endif()
+
+# HACK: Declare a couple of source files as optionally compiled to satisfy the
+# missing-file-checker in LLVM's weird CMake build.
+set(LLVM_OPTIONAL_SOURCES
+ ValueMapTest.cpp
+ )
+
+add_llvm_unittest(IRTests
+ ${IRSources}
+ )