summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2014-01-26 12:34:48 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2014-01-26 12:34:48 +0000
commit4bae3c4635d9009685bd09565cff85fca6c3a91d (patch)
tree12960b43e367fa1b25d8e1d23a33674a52db0976 /CMakeLists.txt
parent42eb9d10d89bcf4c2a6d5b8e03954815f1933137 (diff)
downloadclang-4bae3c4635d9009685bd09565cff85fca6c3a91d.tar.gz
clang-4bae3c4635d9009685bd09565cff85fca6c3a91d.tar.bz2
clang-4bae3c4635d9009685bd09565cff85fca6c3a91d.tar.xz
[CMake] Always set CMAKE_INCLUDE_CURRENT_DIR.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@200144 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e93162640..c4f61df191 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,7 +86,6 @@ if( CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR )
set(LLVM_INCLUDE_TESTS ON)
endif()
- set(CMAKE_INCLUDE_CURRENT_DIR ON)
include_directories("${LLVM_BINARY_DIR}/include" "${LLVM_MAIN_INCLUDE_DIR}")
link_directories("${LLVM_LIBRARY_DIR}")
@@ -341,6 +340,8 @@ macro(add_clang_executable name)
set_target_properties(${name} PROPERTIES FOLDER "Clang executables")
endmacro(add_clang_executable)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
include_directories(BEFORE
${CMAKE_CURRENT_BINARY_DIR}/include
${CMAKE_CURRENT_SOURCE_DIR}/include