summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Rose <jordan_rose@apple.com>2013-02-08 07:28:25 +0000
committerJordan Rose <jordan_rose@apple.com>2013-02-08 07:28:25 +0000
commit6bbaa772515e5bd021f38358667746db40ae54d2 (patch)
treefe138422c4061225a1f27b9a0356d183c160fac8 /CMakeLists.txt
parent63eb156f663a869af8f7360165f85ff31dc95d1f (diff)
downloadclang-6bbaa772515e5bd021f38358667746db40ae54d2.tar.gz
clang-6bbaa772515e5bd021f38358667746db40ae54d2.tar.bz2
clang-6bbaa772515e5bd021f38358667746db40ae54d2.tar.xz
CMake: Include Clang unit tests in check-clang target in standalone builds.
Also, remove CLANG_BUILD_TESTS option. It won't have consistent behavior between standalone and non-standalone builds, so I'm not going to bother hooking it up for standalone builds. LLVM_BUILD_TESTS will continue to control unit test inclusion in the "all" target in non-standalone builds. Finally, fix the default value of CLANG_INCLUDE_TESTS, which was being set to the boolean value of "LLVM_INCLUDE_TESTS", i.e. OFF, rather than actually reading the variable ${LLVM_INCLUDE_TESTS}! If you picked up my earlier commit, YOU WILL HAVE TO MANUALLY SET THIS OPTION BACK ON. My apologies! Part two of r174691 (allow the unit tests to be built in standalone mode). git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@174698 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d1c8cec176..14fe46fe6e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -279,17 +279,12 @@ add_subdirectory(examples)
# TODO: docs.
add_subdirectory(test)
-option(CLANG_BUILD_TESTS
- "Build Clang unit tests. If OFF, just generate build targets."
- LLVM_BUILD_TESTS)
option(CLANG_INCLUDE_TESTS
"Generate build targets for the Clang unit tests."
- LLVM_INCLUDE_TESTS)
+ ${LLVM_INCLUDE_TESTS})
if( CLANG_INCLUDE_TESTS )
add_subdirectory(unittests)
-elseif( CLANG_BUILD_TESTS )
- message(FATAL_ERROR "CLANG_BUILD_TESTS requires CLANG_INCLUDE_TESTS")
endif()
# Workaround for MSVS10 to avoid the Dialog Hell