summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Gottesman <mgottesman@apple.com>2013-08-20 07:09:54 +0000
committerMichael Gottesman <mgottesman@apple.com>2013-08-20 07:09:54 +0000
commit7758bb561bc97c6a6292369bb3b5b1b8b6468f47 (patch)
tree119cb63f4f451f093d291d0d4c004077b0782ca0 /CMakeLists.txt
parent4857638fffc1ce4048d51422ce573efe8c2c8dba (diff)
downloadclang-7758bb561bc97c6a6292369bb3b5b1b8b6468f47.tar.gz
clang-7758bb561bc97c6a6292369bb3b5b1b8b6468f47.tar.bz2
clang-7758bb561bc97c6a6292369bb3b5b1b8b6468f47.tar.xz
[autotools->cmake] Move add_subdirectory(test) inside CLANG_INCLUDE_TESTS to match the behavior of the LLVM where LLVM_INCLUDE_TESTS controls whether tests is included.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@188760 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54ec745e82..e6863b25dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -320,9 +320,9 @@ option(CLANG_INCLUDE_TESTS
${LLVM_INCLUDE_TESTS})
# TODO: docs.
-add_subdirectory(test)
if( CLANG_INCLUDE_TESTS )
+ add_subdirectory(test)
add_subdirectory(unittests)
endif()