summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlp Toker <alp@nuanti.com>2014-06-06 06:58:25 +0000
committerAlp Toker <alp@nuanti.com>2014-06-06 06:58:25 +0000
commit7ea7c590eb103c9b7b4998b4636f5bef07832550 (patch)
tree0693146992ea72413eeeeb252418ada5e869d51d /CMakeLists.txt
parent6e650a52d12a356ff58a79e43d82588e8c64a378 (diff)
downloadclang-7ea7c590eb103c9b7b4998b4636f5bef07832550.tar.gz
clang-7ea7c590eb103c9b7b4998b4636f5bef07832550.tar.bz2
clang-7ea7c590eb103c9b7b4998b4636f5bef07832550.tar.xz
Devise a package-private means to determine the LLVM version string
This will unbreak clang vendor builds as a follow-up to r210238, now that we can't poke into LLVM's private config.h (nor should the string be exposed by llvm-config.h). This hopefully removes for good the last include of LLVM's config.h. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@210313 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ece6bf8bce..28f4e3fb81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -156,6 +156,9 @@ if( CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR )
endif()
set( CLANG_BUILT_STANDALONE 1 )
+ set(BACKEND_PACKAGE_STRING "LLVM ${LLVM_PACKAGE_VERSION}")
+else()
+ set(BACKEND_PACKAGE_STRING "${PACKAGE_STRING}")
endif()
find_package(LibXml2)