summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2013-12-16 16:03:21 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2013-12-16 16:03:21 +0000
commitaa58952ce3eb66489aeed73c1efd5b47b496b0a0 (patch)
tree28a59a3da8c5dc3688ae66862c6b6f2206daabcd /CMakeLists.txt
parent1f69f4c27bdb72c82109450ebd4c2a2803a4aaa7 (diff)
downloadclang-aa58952ce3eb66489aeed73c1efd5b47b496b0a0.tar.gz
clang-aa58952ce3eb66489aeed73c1efd5b47b496b0a0.tar.bz2
clang-aa58952ce3eb66489aeed73c1efd5b47b496b0a0.tar.xz
[CMake] Introduce CLANG_RUNTIME_OUTPUT_INTDIR and CLANG_LIBRARY_OUTPUT_INTDIR.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@197395 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8d02bf05f8..8db8a9a005 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -103,6 +103,9 @@ set(CLANG_VENDOR_UTI "org.llvm.clang" CACHE STRING
set(CLANG_SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR})
set(CLANG_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR})
+set(CLANG_RUNTIME_OUTPUT_INTDIR ${CMAKE_BINARY_DIR}/bin/${CMAKE_CFG_INTDIR})
+set(CLANG_LIBRARY_OUTPUT_INTDIR ${CMAKE_BINARY_DIR}/lib/${CMAKE_CFG_INTDIR})
+
if( CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR AND NOT MSVC_IDE )
message(FATAL_ERROR "In-source builds are not allowed. CMake would overwrite "
"the makefiles distributed with LLVM. Please create a directory and run cmake "