summaryrefslogtreecommitdiff
path: root/examples/analyzer-plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2014-01-23 15:33:44 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2014-01-23 15:33:44 +0000
commit2fa9590f9e7a9986858de135f772dcc196476f11 (patch)
tree0fee71b0b27f6ed25036422782d9c0451c5f914f /examples/analyzer-plugin/CMakeLists.txt
parentb54f0d24abdd61d13da2c10c0c18428c76dcd193 (diff)
downloadclang-2fa9590f9e7a9986858de135f772dcc196476f11.tar.gz
clang-2fa9590f9e7a9986858de135f772dcc196476f11.tar.bz2
clang-2fa9590f9e7a9986858de135f772dcc196476f11.tar.xz
[CMake] Parameterize MODULE and SHARED in add_clang_library().
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@199902 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'examples/analyzer-plugin/CMakeLists.txt')
-rw-r--r--examples/analyzer-plugin/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/examples/analyzer-plugin/CMakeLists.txt b/examples/analyzer-plugin/CMakeLists.txt
index fa8c4fcb32..9984880b2e 100644
--- a/examples/analyzer-plugin/CMakeLists.txt
+++ b/examples/analyzer-plugin/CMakeLists.txt
@@ -1,10 +1,8 @@
-set(MODULE TRUE)
-
set(LLVM_LINK_COMPONENTS
Support
)
-add_clang_library(SampleAnalyzerPlugin MainCallChecker.cpp)
+add_clang_library(SampleAnalyzerPlugin MODULE MainCallChecker.cpp)
add_dependencies(SampleAnalyzerPlugin
ClangAttrClasses