summaryrefslogtreecommitdiff
path: root/include/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2009-03-16 23:06:59 +0000
committerDouglas Gregor <dgregor@apple.com>2009-03-16 23:06:59 +0000
commita393e9eedcc28b25f521a4feceb3b56e3d0d360f (patch)
tree666937547a17f428a2bcbaebc8a82c97798871dd /include/clang/CMakeLists.txt
parent8c84417776e57d58ab573b2f4c485e67cb68d996 (diff)
downloadclang-a393e9eedcc28b25f521a4feceb3b56e3d0d360f.tar.gz
clang-a393e9eedcc28b25f521a4feceb3b56e3d0d360f.tar.bz2
clang-a393e9eedcc28b25f521a4feceb3b56e3d0d360f.tar.xz
Build system changes to use TableGen to generate the various
diagnostics. This builds on the patch that Sebastian committed and then revert. Major differences are: - We don't remove or use the current ".def" files. Instead, for now, we just make sure that we're building the ".inc" files. - Fixed CMake makefiles to run TableGen and build the ".inc" files when needed. Tested with both the Xcode and Makefile generators provided by CMake, so it should be solid. - Fixed normal makefiles to handle out-of-source builds that involve the ".inc" files. I'll send a separate patch to the list with Sebastian's changes that eliminate the use of the .def files. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@67058 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'include/clang/CMakeLists.txt')
-rw-r--r--include/clang/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/clang/CMakeLists.txt b/include/clang/CMakeLists.txt
new file mode 100644
index 0000000000..39e3698a16
--- /dev/null
+++ b/include/clang/CMakeLists.txt
@@ -0,0 +1 @@
+add_subdirectory(Basic)