summaryrefslogtreecommitdiff
path: root/include/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Ballman <aaron@aaronballman.com>2014-03-27 20:19:24 +0000
committerAaron Ballman <aaron@aaronballman.com>2014-03-27 20:19:24 +0000
commitaf55a6bbeea1c29624830af45fced83349edafa2 (patch)
tree14ad7d920a15a17a06922d360f519fcadaf0543c /include/clang/CMakeLists.txt
parentebece3658833fd3e7423738fe3a63b7ff4a4fb09 (diff)
downloadclang-af55a6bbeea1c29624830af45fced83349edafa2.tar.gz
clang-af55a6bbeea1c29624830af45fced83349edafa2.tar.bz2
clang-af55a6bbeea1c29624830af45fced83349edafa2.tar.xz
Clean up the __has_attribute implementation without modifying its behavior.
Replaces the tablegen-driven AttrSpellings.inc, which lived in the lexing layer with AttrHasAttributeImpl.inc, which lives in the basic layer. Updates the preprocessor to call through to this new functionality which can take additional information into account (such as scopes and syntaxes). Expose the ability for parts of the compiler to ask whether an attribute is supported for a given spelling (including scope), syntax, triple and language options. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@204952 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'include/clang/CMakeLists.txt')
-rw-r--r--include/clang/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/include/clang/CMakeLists.txt b/include/clang/CMakeLists.txt
index 71c37fda78..1d8aecd3b2 100644
--- a/include/clang/CMakeLists.txt
+++ b/include/clang/CMakeLists.txt
@@ -1,7 +1,6 @@
add_subdirectory(AST)
add_subdirectory(Basic)
add_subdirectory(Driver)
-add_subdirectory(Lex)
add_subdirectory(Parse)
add_subdirectory(Sema)
add_subdirectory(Serialization)