summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorArgyrios Kyrtzidis <akyrtzi@gmail.com>2011-07-09 20:00:58 +0000
committerArgyrios Kyrtzidis <akyrtzi@gmail.com>2011-07-09 20:00:58 +0000
commit69325d5b7cfecf1b3128745efc33612aedf1b8b4 (patch)
treeddd1627268276e97d9a2394625f3aff4b904f5ec /tools/CMakeLists.txt
parent8dd5cdfc462026648b480adaf774e24bc620f7c3 (diff)
downloadclang-69325d5b7cfecf1b3128745efc33612aedf1b8b4.tar.gz
clang-69325d5b7cfecf1b3128745efc33612aedf1b8b4.tar.bz2
clang-69325d5b7cfecf1b3128745efc33612aedf1b8b4.tar.xz
[arcmt] Introduce new '-ccc-arcmt-migrate <path>' ARC migration driver option.
This is a new mode of migration, where we avoid modifying the original files but we emit temporary files instead. <path> will be used to keep migration process metadata. Currently the temporary files that are produced are put in the system's temp directory but we can put them in the <path> if is necessary. Also introduce new ARC migration functions in libclang whose only purpose, currently, is to accept <path> and provide pairs of original file/transformed file to map from the originals to the files after transformations are applied. Finally introduce the c-arcmt-test utility that exercises the new libclang functions, update arcmt-test, and add tests for the whole process. rdar://9735086. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@134844 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 8f8aa097ce..aff437fd46 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -1,4 +1,5 @@
add_subdirectory(libclang)
add_subdirectory(c-index-test)
add_subdirectory(arcmt-test)
+add_subdirectory(c-arcmt-test)
add_subdirectory(driver)