summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2013-12-03 18:02:51 +0000
committerHans Wennborg <hans@hanshq.net>2013-12-03 18:02:51 +0000
commitea654c32d9d69ff1ece6211fc5cf92f1e0a9e3e2 (patch)
tree43b3dca287b5d0ef9d10cb1d7759920f86cf2e4d /tools/CMakeLists.txt
parent95cedc0524d4c3888ce725395ecc8a6b2faffa89 (diff)
downloadclang-ea654c32d9d69ff1ece6211fc5cf92f1e0a9e3e2.tar.gz
clang-ea654c32d9d69ff1ece6211fc5cf92f1e0a9e3e2.tar.bz2
clang-ea654c32d9d69ff1ece6211fc5cf92f1e0a9e3e2.tar.xz
CMake: enable building the clang-format vs plugin
This makes it possible to build the clang-format vs plugin from the cmake build. It is a hack, as it shells out to "devenv" to actually build it, but it's hidden away in a corner behind a flag, and it provides a convenient way of building the plug-in from the command-line together with the rest of clang. Differential Revision: http://llvm-reviews.chandlerc.com/D2310 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@196299 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index fef0adc621..58be615e85 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -2,6 +2,7 @@ add_subdirectory(diagtool)
add_subdirectory(driver)
if(CLANG_ENABLE_REWRITER)
add_subdirectory(clang-format)
+ add_subdirectory(clang-format-vs)
endif()
if(CLANG_ENABLE_ARCMT)