summaryrefslogtreecommitdiff
path: root/tools/clang-format/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Jasper <djasper@google.com>2013-03-20 09:53:23 +0000
committerDaniel Jasper <djasper@google.com>2013-03-20 09:53:23 +0000
commit7c4a9a04b4b2a44259b34078434e087987872095 (patch)
treea8f60cc98bef2e1ba8f1f8615a56316bd45ef9c2 /tools/clang-format/CMakeLists.txt
parent9322aaee900b872c98f8fc10b38a231cb1e9b57a (diff)
downloadclang-7c4a9a04b4b2a44259b34078434e087987872095.tar.gz
clang-7c4a9a04b4b2a44259b34078434e087987872095.tar.bz2
clang-7c4a9a04b4b2a44259b34078434e087987872095.tar.xz
Add clang-format binary to cfe.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@177506 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/clang-format/CMakeLists.txt')
-rw-r--r--tools/clang-format/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/clang-format/CMakeLists.txt b/tools/clang-format/CMakeLists.txt
new file mode 100644
index 0000000000..c86a920841
--- /dev/null
+++ b/tools/clang-format/CMakeLists.txt
@@ -0,0 +1,17 @@
+set(LLVM_LINK_COMPONENTS support)
+set(LLVM_USED_LIBS clangFormat clangTooling clangBasic clangAST)
+
+add_clang_executable(clang-format
+ ClangFormat.cpp
+ )
+
+target_link_libraries(clang-format
+ clangFormat
+ clangTooling
+ clangBasic
+ clangRewriteFrontend
+ )
+
+install(TARGETS clang-format
+ RUNTIME DESTINATION bin)
+