summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2011-05-31 23:49:32 +0000
committerManuel Klimek <klimek@google.com>2011-05-31 23:49:32 +0000
commit64cbdf370984783911bb6d3bc25ec35a8b59e998 (patch)
treed9f1e5c11584852365aeef877c1f1a36db5548e3 /unittests/CMakeLists.txt
parentd65e091631cc521fcb95a16d6587c0fed8b7164b (diff)
downloadclang-64cbdf370984783911bb6d3bc25ec35a8b59e998.tar.gz
clang-64cbdf370984783911bb6d3bc25ec35a8b59e998.tar.bz2
clang-64cbdf370984783911bb6d3bc25ec35a8b59e998.tar.xz
This patch implements an AST matching framework that allows to write
tools that match on the C++ ASTs. The main interface is in ASTMatchers.h, an example implementation of a tool that removes redundant .c_str() calls is in the example RemoveCStrCalls.cpp. Various contributions: Zhanyong Wan, Chandler Carruth, Marcin Kowalczyk, Wei Xu, James Dennett. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@132374 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index cc2d5f4f83..1fc11ab66e 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -69,3 +69,8 @@ add_clang_unittest(JsonCompileCommandLineDatabase
Tooling/JsonCompileCommandLineDatabaseTest.cpp
USED_LIBS gtest gtest_main clangTooling
)
+
+add_clang_unittest(ASTMatchersTest
+ Tooling/ASTMatchersTest.cpp
+ USED_LIBS gtest gtest_main clangTooling
+ )