summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2011-04-21 18:37:41 +0000
committerManuel Klimek <klimek@google.com>2011-04-21 18:37:41 +0000
commitcf3ce5d89628b3955c638fb102c8dc4c24e1986d (patch)
tree23b117ad61ea2246d4550d24f954d12dc2e90d49 /unittests/CMakeLists.txt
parent0e02f6ef48a098cc27a250e644415038c2fa52a5 (diff)
downloadclang-cf3ce5d89628b3955c638fb102c8dc4c24e1986d.tar.gz
clang-cf3ce5d89628b3955c638fb102c8dc4c24e1986d.tar.bz2
clang-cf3ce5d89628b3955c638fb102c8dc4c24e1986d.tar.xz
Adds a function to run FrontendActions over in-memory code. This is
the first step towards a standalone Clang tool infrastructure. The plan is to make it easy to build command line tools that run over the AST of source files in a project outside of the build system. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@129924 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index 112d6a0e50..dd6bad5fa9 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -59,3 +59,8 @@ add_clang_unittest(Frontend
Frontend/FrontendActionTest.cpp
USED_LIBS gtest gtest_main clangFrontend
)
+
+add_clang_unittest(Tooling
+ Tooling/ToolingTest.cpp
+ USED_LIBS gtest gtest_main clangTooling
+ )