summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorArgyrios Kyrtzidis <akyrtzi@gmail.com>2011-12-21 16:56:29 +0000
committerArgyrios Kyrtzidis <akyrtzi@gmail.com>2011-12-21 16:56:29 +0000
commitd7711ec430fde5706f85ba6c4b85283a8e743ff7 (patch)
treed4c9d96c8bc778dd746b922803dcdef41f18c074 /unittests/CMakeLists.txt
parent87dd4f7f43593d86add23faab58e7393aaa2219f (diff)
downloadclang-d7711ec430fde5706f85ba6c4b85283a8e743ff7.tar.gz
clang-d7711ec430fde5706f85ba6c4b85283a8e743ff7.tar.bz2
clang-d7711ec430fde5706f85ba6c4b85283a8e743ff7.tar.xz
For SourceManager::isBeforeInTranslationUnit(), have it consider macro arg expanded
token locations as coming before the closing ')' of a function macro expansion. Include a unit test for SourceManager. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@147056 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index cb44dc59dc..4b662e46f4 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -52,7 +52,8 @@ endif()
add_clang_unittest(Basic
Basic/FileManagerTest.cpp
- USED_LIBS gtest gtest_main clangBasic
+ Basic/SourceManagerTest.cpp
+ USED_LIBS gtest gtest_main clangLex
)
add_clang_unittest(Frontend