summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d1c8cec176..14fe46fe6e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -279,17 +279,12 @@ add_subdirectory(examples)
# TODO: docs.
add_subdirectory(test)
-option(CLANG_BUILD_TESTS
- "Build Clang unit tests. If OFF, just generate build targets."
- LLVM_BUILD_TESTS)
option(CLANG_INCLUDE_TESTS
"Generate build targets for the Clang unit tests."
- LLVM_INCLUDE_TESTS)
+ ${LLVM_INCLUDE_TESTS})
if( CLANG_INCLUDE_TESTS )
add_subdirectory(unittests)
-elseif( CLANG_BUILD_TESTS )
- message(FATAL_ERROR "CLANG_BUILD_TESTS requires CLANG_INCLUDE_TESTS")
endif()
# Workaround for MSVS10 to avoid the Dialog Hell