summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2013-05-23 11:10:23 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2013-05-23 11:10:23 +0000
commit0a2cc37712a452525f9f03b3bf67b1f0a97c8d3a (patch)
tree612da280214deb0c9eb100fdb10515bb4d0c7bb0 /CMakeLists.txt
parentfc1a61203fec6797060744c5c6754b0ae924f5b2 (diff)
downloadcompiler-rt-0a2cc37712a452525f9f03b3bf67b1f0a97c8d3a.tar.gz
compiler-rt-0a2cc37712a452525f9f03b3bf67b1f0a97c8d3a.tar.bz2
compiler-rt-0a2cc37712a452525f9f03b3bf67b1f0a97c8d3a.tar.xz
[sanitizer] Interceptors for gethostbyname and friends.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@182573 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f94af32c..a57751ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -127,6 +127,7 @@ set(SANITIZER_COMMON_CFLAGS
-fomit-frame-pointer
-funwind-tables
-fno-stack-protector
+ -Wno-gnu # Variadic macros with 0 arguments for ...
-O3
)
if(NOT WIN32)