summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2012-09-05 09:00:03 +0000
committerAlexey Samsonov <samsonov@google.com>2012-09-05 09:00:03 +0000
commit0f7d4a4ad69ad20053d8b78c611853e778bd465a (patch)
treeb0f41f3cbe745ea415efc511a4fd1533609cb4bb /CMakeLists.txt
parent656e4eef01b935e7d356e697e0f3ef4c99be2fbf (diff)
downloadcompiler-rt-0f7d4a4ad69ad20053d8b78c611853e778bd465a.tar.gz
compiler-rt-0f7d4a4ad69ad20053d8b78c611853e778bd465a.tar.bz2
compiler-rt-0f7d4a4ad69ad20053d8b78c611853e778bd465a.tar.xz
[ASan] hoist more compile flags to SANITIZER_COMMON_CFLAGS var and add the rest of flags/defs from old Makefile to CMake
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@163204 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 17268c8b..08203600 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,9 +77,12 @@ endfunction()
# Provide some common commmandline flags for Sanitizer runtimes.
set(SANITIZER_COMMON_CFLAGS
-fPIC
+ -fno-builtin
-fno-exceptions
+ -fomit-frame-pointer
-funwind-tables
-fvisibility=hidden
+ -O3
)
if(SUPPORTS_NO_VARIADIC_MACROS_FLAG)
list(APPEND SANITIZER_COMMON_CFLAGS -Wno-variadic-macros)
@@ -89,6 +92,9 @@ check_cxx_compiler_flag(-Wno-c99-extensions
if(SUPPORTS_NO_C99_EXTENSIONS_FLAG)
list(APPEND SANITIZER_COMMON_CFLAGS -Wno-c99-extensions)
endif()
+if(APPLE)
+ list(APPEND SANITIZER_COMMON_CFLAGS -mmacosx-version-min=10.5)
+endif()
# Because compiler-rt spends a lot of time setting up custom compile flags,
# define a handy helper function for it. The compile flags setting in CMake