summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2012-09-13 10:23:45 +0000
committerAlexey Samsonov <samsonov@google.com>2012-09-13 10:23:45 +0000
commit1d34a48ea9fe3b133cf96ef5e84fee44d9b24c7f (patch)
treeaab71df057d630055e44bb381c4879678760d0b8 /CMakeLists.txt
parent8019524fdba2eb50ea6fac5f07d938165ad1e065 (diff)
downloadcompiler-rt-1d34a48ea9fe3b133cf96ef5e84fee44d9b24c7f.tar.gz
compiler-rt-1d34a48ea9fe3b133cf96ef5e84fee44d9b24c7f.tar.bz2
compiler-rt-1d34a48ea9fe3b133cf96ef5e84fee44d9b24c7f.tar.xz
[Sanitizer] don't use -Werror as default compile flag for sanitizer runtimes - people may use too many distinct/old host compilers
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@163784 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0b728c21..67c7799a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,7 +62,6 @@ endfunction()
# Provide some common commmandline flags for Sanitizer runtimes.
set(SANITIZER_COMMON_CFLAGS
- -Werror
-fPIC
-fno-builtin
-fno-exceptions