summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-01-18 16:51:07 +0000
committerAlexey Samsonov <samsonov@google.com>2013-01-18 16:51:07 +0000
commit43b4b9c18a7a588a60b9d976391ad8e2f5f9a309 (patch)
tree7ed618e62e12ce199f079a5a8cc3b0b7a8e3fa4c /CMakeLists.txt
parentdedba5d6b0664218b1b1109f024a1ab151642776 (diff)
downloadcompiler-rt-43b4b9c18a7a588a60b9d976391ad8e2f5f9a309.tar.gz
compiler-rt-43b4b9c18a7a588a60b9d976391ad8e2f5f9a309.tar.bz2
compiler-rt-43b4b9c18a7a588a60b9d976391ad8e2f5f9a309.tar.xz
CMake: Generalize build rules for different arches for sanitizer_common, asan, ubsan
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@172829 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b71d6ac..04d6e976 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,6 +124,11 @@ if(APPLE)
list(APPEND SANITIZER_COMMON_CFLAGS -mmacosx-version-min=10.5)
endif()
+# Architectures supported by Sanitizer runtimes. Specific sanitizers may
+# support only subset of these (e.g. TSan works on x86_64 only).
+filter_available_targets(SANITIZER_COMMON_SUPPORTED_ARCH
+ x86_64 i386)
+
# Compute the Clang version from the LLVM version.
# FIXME: We should be able to reuse CLANG_VERSION variable calculated
# in Clang cmake files, instead of copying the rules here.