summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2012-09-12 07:38:47 +0000
committerAlexey Samsonov <samsonov@google.com>2012-09-12 07:38:47 +0000
commitb43d6a8ca10b9af8a903e8726003ae7767f9e823 (patch)
treeab08b76e6e37d2ca0c1c6e6966252802bddb4703 /CMakeLists.txt
parentb66bfd1e28776f0a350b9c197926c2c172678603 (diff)
downloadcompiler-rt-b43d6a8ca10b9af8a903e8726003ae7767f9e823.tar.gz
compiler-rt-b43d6a8ca10b9af8a903e8726003ae7767f9e823.tar.bz2
compiler-rt-b43d6a8ca10b9af8a903e8726003ae7767f9e823.tar.xz
[Sanitizer] first effort to start building ASan runtime with -Werror in CMake build
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@163686 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d336eedd..a10a83bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,6 +62,7 @@ endfunction()
# Provide some common commmandline flags for Sanitizer runtimes.
set(SANITIZER_COMMON_CFLAGS
+ -Werror
-fPIC
-fno-builtin
-fno-exceptions