summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2012-09-24 11:43:40 +0000
committerAlexey Samsonov <samsonov@google.com>2012-09-24 11:43:40 +0000
commitb46941a1d23012491a7a8a52718cacbde3c19ba1 (patch)
tree3f7b5776b228f5bd3b21cf8880c1443ef1d34368 /CMakeLists.txt
parentc6439621280cda29433eeed5abb62ed9833ba45a (diff)
downloadcompiler-rt-b46941a1d23012491a7a8a52718cacbde3c19ba1.tar.gz
compiler-rt-b46941a1d23012491a7a8a52718cacbde3c19ba1.tar.bz2
compiler-rt-b46941a1d23012491a7a8a52718cacbde3c19ba1.tar.xz
[ASan] Apply some ASan-relevant pieces of patch by Ruben Van Boxem. In the same time, remove ASan from CMake build on Windows after conversation with Timur. We don't want to support building ASan on Windows until it is in a working state.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@164486 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 67c7799a..d5f66964 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,9 +67,11 @@ set(SANITIZER_COMMON_CFLAGS
-fno-exceptions
-fomit-frame-pointer
-funwind-tables
- -fvisibility=hidden
-O3
)
+if(NOT WIN32)
+ list(APPEND SANITIZER_COMMON_CFLAGS -fvisibility=hidden)
+endif()
check_cxx_compiler_flag(-Wno-variadic-macros SUPPORTS_NO_VARIADIC_MACROS_FLAG)
if(SUPPORTS_NO_VARIADIC_MACROS_FLAG)
list(APPEND SANITIZER_COMMON_CFLAGS -Wno-variadic-macros)