summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2012-08-07 12:14:29 +0000
committerAlexey Samsonov <samsonov@google.com>2012-08-07 12:14:29 +0000
commitbd1700415c7f5c6c9b9d562b6fee3414360c3dc2 (patch)
treee6e995b46f8c80caf71a9ec26c9458608841b6e6 /CMakeLists.txt
parent9b7409ad61a3448f44fa9911debdd52ad0a6d3c8 (diff)
downloadcompiler-rt-bd1700415c7f5c6c9b9d562b6fee3414360c3dc2.tar.gz
compiler-rt-bd1700415c7f5c6c9b9d562b6fee3414360c3dc2.tar.bz2
compiler-rt-bd1700415c7f5c6c9b9d562b6fee3414360c3dc2.tar.xz
[compiler-rt] CMake build: if LLVM_BUILD_32_BITS is on, then -m32 is added to llvm definitions. Let us override this by explicitly adding -m64 compiler flag when building compiler-rt libraries for x86_64 target
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@161415 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 97835a1e..d8985c21 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,7 +21,7 @@ cmake_minimum_required(VERSION 2.8.8)
# Detect whether the current target platform is 32-bit or 64-bit, and setup
# the correct commandline flags needed to attempt to target 32-bit and 64-bit.
-if(CMAKE_SIZEOF_VOID_P EQUAL 4)
+if(CMAKE_SIZEOF_VOID_P EQUAL 4 OR LLVM_BUILD_32_BITS)
set(TARGET_X86_64_CFLAGS "-m64")
set(TARGET_I386_CFLAGS "")
else()