summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-10-01 12:52:15 +0000
committerAlexey Samsonov <samsonov@google.com>2013-10-01 12:52:15 +0000
commitc349466646968133e0bad48d24e267580bad6c07 (patch)
tree57201c4bd6830b4c84ac23138cc23b25acb6e167 /CMakeLists.txt
parent2946f13d6ca0cfc46d74c12e97dc40a17a7d232f (diff)
downloadcompiler-rt-c349466646968133e0bad48d24e267580bad6c07.tar.gz
compiler-rt-c349466646968133e0bad48d24e267580bad6c07.tar.bz2
compiler-rt-c349466646968133e0bad48d24e267580bad6c07.tar.xz
Add top-level CMake 'compiler-rt' target to build all compiler-rt libraries
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@191747 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4a7be9c3..123b60ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,9 @@ include(LLVMParseArguments)
# runtime libraries.
cmake_minimum_required(VERSION 2.8.8)
+# Top level target used to build all compiler-rt libraries.
+add_custom_target(compiler-rt)
+
# Compute the Clang version from the LLVM version.
# FIXME: We should be able to reuse CLANG_VERSION variable calculated
# in Clang cmake files, instead of copying the rules here.