summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2012-09-04 14:52:21 +0000
committerAlexey Samsonov <samsonov@google.com>2012-09-04 14:52:21 +0000
commitc5fee8e40d369e93ab91011c18347395167ff132 (patch)
tree88ae54c2b633078ab5d978752c11176b4f96c2af /CMakeLists.txt
parent92656f8f1210b12c993efe898f39f883a634f1fb (diff)
downloadcompiler-rt-c5fee8e40d369e93ab91011c18347395167ff132.tar.gz
compiler-rt-c5fee8e40d369e93ab91011c18347395167ff132.tar.bz2
compiler-rt-c5fee8e40d369e93ab91011c18347395167ff132.tar.xz
[compiler-rt] Recurse into 'utils' directory in CMake build of compiler-rt, enable build of llvm-symbolizer binary (currently for one target only)
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@163138 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 844660fe..17268c8b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -103,6 +103,9 @@ endfunction()
# Add the public header's directory to the includes for all of compiler-rt.
include_directories(include)
+# Build utils before building compiler-rt library.
+add_subdirectory(utils)
+
add_subdirectory(lib)
if(LLVM_INCLUDE_TESTS)