summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-03-25 10:31:49 +0000
committerAlexey Samsonov <samsonov@google.com>2013-03-25 10:31:49 +0000
commite374e4ece521692173aad355420d03e1b2cd819a (patch)
treef73cd196db1aaf9edf3802d639f36e63e44694f7 /CMakeLists.txt
parentf58a1ea0483690df5faa93bbde8d4301170c542d (diff)
downloadcompiler-rt-e374e4ece521692173aad355420d03e1b2cd819a.tar.gz
compiler-rt-e374e4ece521692173aad355420d03e1b2cd819a.tar.bz2
compiler-rt-e374e4ece521692173aad355420d03e1b2cd819a.tar.xz
[Sanitizer] Compile sanitizer runtimes with -Wno-non-virtual-dtor. Virtual dtors may be a problem for us, as sanitizer runtime should not generally assume libstdc++ presence.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@177860 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 240572e3..5ce55bd9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -147,6 +147,12 @@ check_cxx_compiler_flag(-Wno-c99-extensions SUPPORTS_NO_C99_EXTENSIONS_FLAG)
if(SUPPORTS_NO_C99_EXTENSIONS_FLAG)
list(APPEND SANITIZER_COMMON_CFLAGS -Wno-c99-extensions)
endif()
+# Sanitizer may not have libstdc++, so we can have problems with virtual
+# destructors.
+check_cxx_compiler_flag(-Wno-non-virtual-dtor SUPPORTS_NO_NON_VIRTUAL_DTOR_FLAG)
+if (SUPPORTS_NO_NON_VIRTUAL_DTOR_FLAG)
+ list(APPEND SANITIZER_COMMON_CFLAGS -Wno-non-virtual-dtor)
+endif()
# Setup min Mac OS X version.
if(APPLE)