summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-08-27 15:08:02 +0000
committerAlexey Samsonov <samsonov@google.com>2013-08-27 15:08:02 +0000
commite5fa243b20bf5e6a097bc58cbedfe6bed8a9b7d1 (patch)
tree44ec546168b34e749d09d3576ee21f598842a330 /CMakeLists.txt
parent0e38a67cd2d877e8680d65878c86c9e7e4fa4b1d (diff)
downloadcompiler-rt-e5fa243b20bf5e6a097bc58cbedfe6bed8a9b7d1.tar.gz
compiler-rt-e5fa243b20bf5e6a097bc58cbedfe6bed8a9b7d1.tar.bz2
compiler-rt-e5fa243b20bf5e6a097bc58cbedfe6bed8a9b7d1.tar.xz
Properly generate lists of exported symbols for sanitizer runtimes
This change adds a Python script that is invoked for the just-built sanitizer runtime to generate the list of exported symbols passed to the linker. By default, it contains interceptors and sanitizer interface functions, but can be extended with tool-specific lists. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@189356 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 67cc51ed..70178488 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,6 +40,7 @@ set(COMPILER_RT_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR})
# Setup custom SDK sysroots.
set(COMPILER_RT_DARWIN_SDK_SYSROOT ${COMPILER_RT_SOURCE_DIR}/SDKs/darwin)
set(COMPILER_RT_LINUX_SDK_SYSROOT ${COMPILER_RT_SOURCE_DIR}/SDKs/linux)
+include(SanitizerUtils)
# Detect whether the current target platform is 32-bit or 64-bit, and setup
# the correct commandline flags needed to attempt to target 32-bit and 64-bit.