summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Gottesman <mgottesman@apple.com>2013-04-01 04:13:03 +0000
committerMichael Gottesman <mgottesman@apple.com>2013-04-01 04:13:03 +0000
commitfd0a789ee62ec37430515dee4bce1e7ced68bb55 (patch)
tree6664690657cb456646432dc387a15918450a9a6a /CMakeLists.txt
parentd475aa8578f4a1955cdb3e3159eda8b229f8c021 (diff)
downloadcompiler-rt-fd0a789ee62ec37430515dee4bce1e7ced68bb55.tar.gz
compiler-rt-fd0a789ee62ec37430515dee4bce1e7ced68bb55.tar.bz2
compiler-rt-fd0a789ee62ec37430515dee4bce1e7ced68bb55.tar.xz
Change the cmake variable COMPILER_RT_CAN_EXECUTE_TESTS to be an option so that it can overwritten.
The reason why this simple change is needed is that I am trying to set up a quick cmake/ninja based buildbot and apple-clang does not support using the sanitizers currently. The default behavior follows exactly what was there before implying that no ones builds should be affected at all. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@178455 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ce55bd9..fe895cf1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -99,11 +99,11 @@ endif()
# and target a unix-like system. On Android we define the rules for building
# unit tests, but don't execute them.
if("${CMAKE_HOST_SYSTEM}" STREQUAL "${CMAKE_SYSTEM}" AND UNIX AND NOT ANDROID)
- set(COMPILER_RT_CAN_EXECUTE_TESTS TRUE)
+ option(COMPILER_RT_CAN_EXECUTE_TESTS "Can we execute instrumented tests" ON)
else()
- set(COMPILER_RT_CAN_EXECUTE_TESTS FALSE)
+ option(COMPILER_RT_CAN_EXECUTE_TESTS "Can we execute instrumented tests" OFF)
endif()
-
+
# Check if compiler-rt is built with libc++.
find_flag_in_string("${CMAKE_CXX_FLAGS}" "-stdlib=libc++"
COMPILER_RT_USES_LIBCXX)