summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2010-01-13 16:12:49 +0000
committerDaniel Dunbar <daniel@zuster.org>2010-01-13 16:12:49 +0000
commitfe4eb31f6b835d1cca3edb43db307ba36f603248 (patch)
tree0b01fcaa0d3a6f17651b04eb006f0fc117e90596 /CMakeLists.txt
parent1f1f71b353fd8335c8f9b0bce6bd32c25b4bd607 (diff)
downloadcompiler-rt-fe4eb31f6b835d1cca3edb43db307ba36f603248.tar.gz
compiler-rt-fe4eb31f6b835d1cca3edb43db307ba36f603248.tar.bz2
compiler-rt-fe4eb31f6b835d1cca3edb43db307ba36f603248.tar.xz
Sink {config.h,ConfigureChecks}.cmake into cmake directory.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@93318 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a57d6a98..483b6737 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,8 +19,9 @@ MACRO_ENSURE_OUT_OF_SOURCE_BUILD(
"${PROJECT_NAME} requires an out of source build. Please create a separate build directory and run 'cmake /path/to/${PROJECT_NAME} [options]' there."
)
-INCLUDE( ConfigureChecks.cmake )
-CONFIGURE_FILE( config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h )
+INCLUDE( ${CMAKE_SOURCE_DIR}/cmake/ConfigureChecks.cmake )
+CONFIGURE_FILE( ${CMAKE_SOURCE_DIR}/cmake/config.h.cmake
+ ${CMAKE_CURRENT_BINARY_DIR}/config.h )
INCLUDE_DIRECTORIES(
${CMAKE_CURRENT_BINARY_DIR}
@@ -46,7 +47,7 @@ IF( BUILD_BLOCKS_RUNTIME )
ELSE( BUILD_BLOCKS_RUNTIME )
MESSAGE(STATUS "No suitable atomic operation routines detected, skipping Blocks Runtime")
ENDIF( BUILD_BLOCKS_RUNTIME )
-
+
ADD_SUBDIRECTORY( lib )
# Enable Test Suit: