summaryrefslogtreecommitdiff
path: root/lib/interception/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2012-08-27 14:28:27 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2012-08-27 14:28:27 +0000
commitb10027729a3b809469f6b6ad40407ca453d6f54a (patch)
treea51b6023b529942d03ffffbd9dddeaf6cf63fa8b /lib/interception/CMakeLists.txt
parent985aaaaf208f43e4b47625e21e9ebc434c5462e3 (diff)
downloadcompiler-rt-b10027729a3b809469f6b6ad40407ca453d6f54a.tar.gz
compiler-rt-b10027729a3b809469f6b6ad40407ca453d6f54a.tar.bz2
compiler-rt-b10027729a3b809469f6b6ad40407ca453d6f54a.tar.xz
CMake build rules for ASan/Android runtime.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@162675 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/interception/CMakeLists.txt')
-rw-r--r--lib/interception/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/interception/CMakeLists.txt b/lib/interception/CMakeLists.txt
index aacecf9b..55046e91 100644
--- a/lib/interception/CMakeLists.txt
+++ b/lib/interception/CMakeLists.txt
@@ -43,4 +43,9 @@ else()
set_target_compile_flags(RTInterception.i386
${INTERCEPTION_CFLAGS} ${TARGET_I386_CFLAGS})
endif()
+ if(CAN_TARGET_ARM_ANDROID)
+ add_library(RTInterception.arm.android OBJECT ${INTERCEPTION_SOURCES})
+ set_target_compile_flags(RTInterception.arm.android
+ ${INTERCEPTION_CFLAGS} ${TARGET_ARM_ANDROID_CFLAGS})
+ endif()
endif()