summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2012-12-21 14:04:52 +0000
committerAlexey Samsonov <samsonov@google.com>2012-12-21 14:04:52 +0000
commit032e833059a673a21facc8e726b5c0c9d1a13d2e (patch)
treedb38d441bfd1ed2373b758060ffa6c521c28c933 /lib/sanitizer_common/CMakeLists.txt
parentfc2bebfdc285342fd00b57c2547cf85357ed3991 (diff)
downloadcompiler-rt-032e833059a673a21facc8e726b5c0c9d1a13d2e.tar.gz
compiler-rt-032e833059a673a21facc8e726b5c0c9d1a13d2e.tar.bz2
compiler-rt-032e833059a673a21facc8e726b5c0c9d1a13d2e.tar.xz
[Sanitizer] CMake build rules for unittests: depend on headers when compiling a file with custom clang.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@170897 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index fb01f27c..975f76fd 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -20,6 +20,30 @@ set(SANITIZER_SOURCES
sanitizer_win.cc
)
+# Explicitly list all sanitizer_common headers. Not all of these are
+# included in sanitizer_common source files, but we need to depend on
+# headers when building our custom unit tests.
+set(SANITIZER_HEADERS
+ sanitizer_allocator.h
+ sanitizer_atomic_clang.h
+ sanitizer_atomic_msvc.h
+ sanitizer_atomic.h
+ sanitizer_common.h
+ sanitizer_common_interceptors.h
+ sanitizer_flags.h
+ sanitizer_internal_defs.h
+ sanitizer_libc.h
+ sanitizer_list.h
+ sanitizer_mutex.h
+ sanitizer_placement_new.h
+ sanitizer_platform_interceptors.h
+ sanitizer_procmaps.h
+ sanitizer_report_decorator.h
+ sanitizer_stackdepot.h
+ sanitizer_stacktrace.h
+ sanitizer_symbolizer.h
+ )
+
set(SANITIZER_CFLAGS ${SANITIZER_COMMON_CFLAGS})
set(SANITIZER_RUNTIME_LIBRARIES)