summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2012-12-20 13:24:21 +0000
committerAlexey Samsonov <samsonov@google.com>2012-12-20 13:24:21 +0000
commit0414b25ab6bd328b96bd48a70382954f30894edf (patch)
tree820ff63863a81d439533b0a4ab4e2cf8dfb3cf4c /lib/sanitizer_common/CMakeLists.txt
parent1894f4a6827c55122fc24a931766c29705ec0bfb (diff)
downloadcompiler-rt-0414b25ab6bd328b96bd48a70382954f30894edf.tar.gz
compiler-rt-0414b25ab6bd328b96bd48a70382954f30894edf.tar.bz2
compiler-rt-0414b25ab6bd328b96bd48a70382954f30894edf.tar.xz
[Sanitizer] Modify CMake build rules for sanitizer_common unit tests: build them with fresh Clang for both 32- and 64-bits (if possible)
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@170691 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index c9eff4db..fb01f27c 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -55,13 +55,5 @@ endif()
# Unit tests for common sanitizer runtime.
if(LLVM_INCLUDE_TESTS)
- # Build stand-alone static sanitizer runtime for use in unit tests.
- add_library(RTSanitizerCommon.test STATIC ${SANITIZER_SOURCES})
- # Build test library with debug info.
- set_target_compile_flags(RTSanitizerCommon.test
- ${SANITIZER_CFLAGS} -g)
- set_target_properties(RTSanitizerCommon.test PROPERTIES
- ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
-
add_subdirectory(tests)
endif()