summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Potapenko <glider@google.com>2013-03-15 14:37:21 +0000
committerAlexander Potapenko <glider@google.com>2013-03-15 14:37:21 +0000
commit3614c16084e8a0dc8ae3418402a2d0c6f8107e39 (patch)
tree89e85bd2394e1ef5570359a0b1034656f1363e07 /lib/sanitizer_common/CMakeLists.txt
parentff5d1fcdd74036fa15d96fafd487397ebf5f202e (diff)
downloadcompiler-rt-3614c16084e8a0dc8ae3418402a2d0c6f8107e39.tar.gz
compiler-rt-3614c16084e8a0dc8ae3418402a2d0c6f8107e39.tar.bz2
compiler-rt-3614c16084e8a0dc8ae3418402a2d0c6f8107e39.tar.xz
[libsanitizer] StopTheWorld in sanitizer_common
StopTheWorld puts the process in a suspended state before running the user-supplied callback. To be used in TSan and in leak checking code. Linux implementation provided. Patch by Sergey Matveev (earthdok@google.com) git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@177156 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index fe817455..e89e207f 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -13,6 +13,7 @@ set(SANITIZER_SOURCES
sanitizer_printf.cc
sanitizer_stackdepot.cc
sanitizer_stacktrace.cc
+ sanitizer_stoptheworld_linux.cc
sanitizer_symbolizer.cc
sanitizer_symbolizer_itanium.cc
sanitizer_symbolizer_linux.cc