summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2012-08-29 00:13:11 +0000
committerChandler Carruth <chandlerc@gmail.com>2012-08-29 00:13:11 +0000
commit60ab090deed8213613643729a7921ef0915ac704 (patch)
tree4f21037c600edc3a73c359c84a7233ced95ad447 /lib/sanitizer_common/CMakeLists.txt
parent80acccf4647c3482c3e3e6ae21e757ba580a5956 (diff)
downloadcompiler-rt-60ab090deed8213613643729a7921ef0915ac704.tar.gz
compiler-rt-60ab090deed8213613643729a7921ef0915ac704.tar.bz2
compiler-rt-60ab090deed8213613643729a7921ef0915ac704.tar.xz
Some flag cleanup for the sanitizer runtimes.
This hoists most of the CFLAGS into a common variable. It also adds detection for -Wno-c99-extensions and uses it to silence a pile of warnings. Finally, it switches to the proper flag -rdynamic. With this, the cmake build is warning free on my bootstrap Linux build. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@162809 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index c4f3b482..cb425a21 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -18,13 +18,7 @@ set(SANITIZER_SOURCES
sanitizer_win.cc
)
-set(SANITIZER_CFLAGS
- -O3
- -fPIC
- -fno-exceptions
- -funwind-tables
- -fvisibility=hidden
- )
+set(SANITIZER_CFLAGS -O3 ${SANITIZER_COMMON_CFLAGS})
set(SANITIZER_COMMON_DEFINITIONS)