summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-03-14 13:54:30 +0000
committerAlexey Samsonov <samsonov@google.com>2013-03-14 13:54:30 +0000
commit6d429cda69b7ccc007ee368a73a6040c6b125afb (patch)
tree28ab71918eed17c5d17a8f76f3561134a21527ba /lib/sanitizer_common/CMakeLists.txt
parent93af5948d3e0c5bdc396f432dd0ae782f499c449 (diff)
downloadcompiler-rt-6d429cda69b7ccc007ee368a73a6040c6b125afb.tar.gz
compiler-rt-6d429cda69b7ccc007ee368a73a6040c6b125afb.tar.bz2
compiler-rt-6d429cda69b7ccc007ee368a73a6040c6b125afb.tar.xz
[Sanitizer] Add generic ThreadRegistry class for sanitizer runtimes. This class holds basic thread bookkeeping logic and allows specific sanitizer runtimes to create thread contexts and mark threads as created/running/joined etc. The class is based on the way we currently store thread contexts in TSan.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@177074 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index d3e5707b..fe817455 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -18,6 +18,7 @@ set(SANITIZER_SOURCES
sanitizer_symbolizer_linux.cc
sanitizer_symbolizer_mac.cc
sanitizer_symbolizer_win.cc
+ sanitizer_thread_registry.cc
sanitizer_win.cc
)
@@ -47,6 +48,7 @@ set(SANITIZER_HEADERS
sanitizer_stackdepot.h
sanitizer_stacktrace.h
sanitizer_symbolizer.h
+ sanitizer_thread_registry.h
)
set(SANITIZER_CFLAGS