summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorKostya Serebryany <kcc@google.com>2013-02-27 11:22:40 +0000
committerKostya Serebryany <kcc@google.com>2013-02-27 11:22:40 +0000
commit6fb47af2d2d305adbfc3d41bea589d1527a364a9 (patch)
treebf89a18e0c1e0b5585d7fe41d94fb79bcf515580 /lib/sanitizer_common/CMakeLists.txt
parent1d2ed3ab71a574aaa0f4cea21333ae2bb786c93a (diff)
downloadcompiler-rt-6fb47af2d2d305adbfc3d41bea589d1527a364a9.tar.gz
compiler-rt-6fb47af2d2d305adbfc3d41bea589d1527a364a9.tar.bz2
compiler-rt-6fb47af2d2d305adbfc3d41bea589d1527a364a9.tar.xz
add Linux syscall wrappers and ThreadLister to sanitizer_common
ThreadLister is a Linux-specific class for obtaining the thread IDs of a process from procfs (/proc/<pid>/task/). It will be used by leak checking code. Also add several syscall wrappers which will be required by the same code that uses ThreadLister, but are not used in ThreadLister itself. Patch by Sergey Matveev git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@176179 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index 56aa3f73..b7628551 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -36,6 +36,7 @@ set(SANITIZER_HEADERS
sanitizer_internal_defs.h
sanitizer_lfstack.h
sanitizer_libc.h
+ sanitizer_linux.h
sanitizer_list.h
sanitizer_mutex.h
sanitizer_placement_new.h