summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-09-16 15:43:23 +0000
committerAlexey Samsonov <samsonov@google.com>2013-09-16 15:43:23 +0000
commit7bb2f9b27ee0210f25b009fb5597383b334dc01e (patch)
treeec6c4b8a235eacdb8e584e620aa0a5513a86fd74 /lib/sanitizer_common/CMakeLists.txt
parentdb6d089de966dc250ceb7d81556a5978943f6efb (diff)
downloadcompiler-rt-7bb2f9b27ee0210f25b009fb5597383b334dc01e.tar.gz
compiler-rt-7bb2f9b27ee0210f25b009fb5597383b334dc01e.tar.bz2
compiler-rt-7bb2f9b27ee0210f25b009fb5597383b334dc01e.tar.xz
Minor enhancements for sanitizer_common build rules
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@190786 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index 54760cb4..63c49630 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -96,7 +96,8 @@ else()
SOURCES $<TARGET_OBJECTS:RTSanitizerCommon.${arch}>
$<TARGET_OBJECTS:RTSanitizerCommonLibc.${arch}>
CFLAGS ${SANITIZER_CFLAGS})
- list(APPEND SANITIZER_RUNTIME_LIBRARIES RTSanitizerCommon.${arch})
+ list(APPEND SANITIZER_RUNTIME_LIBRARIES RTSanitizerCommon.${arch}
+ RTSanitizerCommonLibc.${arch})
endforeach()
endif()