summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2012-09-12 07:38:47 +0000
committerAlexey Samsonov <samsonov@google.com>2012-09-12 07:38:47 +0000
commitb43d6a8ca10b9af8a903e8726003ae7767f9e823 (patch)
treeab08b76e6e37d2ca0c1c6e6966252802bddb4703 /lib/sanitizer_common/CMakeLists.txt
parentb66bfd1e28776f0a350b9c197926c2c172678603 (diff)
downloadcompiler-rt-b43d6a8ca10b9af8a903e8726003ae7767f9e823.tar.gz
compiler-rt-b43d6a8ca10b9af8a903e8726003ae7767f9e823.tar.bz2
compiler-rt-b43d6a8ca10b9af8a903e8726003ae7767f9e823.tar.xz
[Sanitizer] first effort to start building ASan runtime with -Werror in CMake build
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@163686 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index 4c24fceb..f3461630 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -58,7 +58,7 @@ if(LLVM_INCLUDE_TESTS)
add_library(RTSanitizerCommon.test STATIC ${SANITIZER_SOURCES})
# Build test library with debug info.
set_target_compile_flags(RTSanitizerCommon.test
- ${SANITIZER_CFLAGS} -g -Werror)
+ ${SANITIZER_CFLAGS} -g)
set_target_properties(RTSanitizerCommon.test PROPERTIES
ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})