summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitry Vyukov <dvyukov@google.com>2013-01-14 08:23:34 +0000
committerDmitry Vyukov <dvyukov@google.com>2013-01-14 08:23:34 +0000
commitb48224c8d19cac76f2af1eba158b9ae26ed1608a (patch)
tree3becc249e254f2314835124783b9fed767361628 /lib/sanitizer_common/CMakeLists.txt
parentd164ed175a61529589938b3db3cab076a19acf67 (diff)
downloadcompiler-rt-b48224c8d19cac76f2af1eba158b9ae26ed1608a.tar.gz
compiler-rt-b48224c8d19cac76f2af1eba158b9ae26ed1608a.tar.bz2
compiler-rt-b48224c8d19cac76f2af1eba158b9ae26ed1608a.tar.xz
asan/tsan: faster memory allocator
1. Increase size classes from 32k to 128k 2. Use lock-free stack in central cache 3. Use blocking mutex when allocate new memory with mmap git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@172388 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index cbf04487..6d4fc25d 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -32,6 +32,7 @@ set(SANITIZER_HEADERS
sanitizer_common_interceptors.h
sanitizer_flags.h
sanitizer_internal_defs.h
+ sanitizer_lfstack.h
sanitizer_libc.h
sanitizer_list.h
sanitizer_mutex.h