summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2013-08-14 13:34:14 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2013-08-14 13:34:14 +0000
commite6e564d232f95719277476308937856328c63682 (patch)
treed105dc30521b963b0dbee415a5d369a561a5507a /lib/sanitizer_common/CMakeLists.txt
parent1528c6cea4593ac7c45d72a74efae4be36ec52f0 (diff)
downloadcompiler-rt-e6e564d232f95719277476308937856328c63682.tar.gz
compiler-rt-e6e564d232f95719277476308937856328c63682.tar.bz2
compiler-rt-e6e564d232f95719277476308937856328c63682.tar.xz
[sanitizer] Split platform_limits_posix into system- and kernel-dependent parts.
This change moves everything depending on kernel headers (mostly ioctl types and ids) into a separate source file. This will reduce the possibility of header conflict on various platforms (most importantly, older glibc versions). This change also removes 2 deprecated ioctls, and symbolic ids for other bunch of ambiguous ioctls (i.e. same id is shared by ioctls with different memory behavior). git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@188369 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index 8141ae68..ab80e081 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -8,6 +8,7 @@ set(SANITIZER_SOURCES
sanitizer_libc.cc
sanitizer_linux.cc
sanitizer_mac.cc
+ sanitizer_platform_limits_linux.cc
sanitizer_platform_limits_posix.cc
sanitizer_posix.cc
sanitizer_printf.cc
@@ -53,6 +54,7 @@ set(SANITIZER_HEADERS
sanitizer_mutex.h
sanitizer_placement_new.h
sanitizer_platform_interceptors.h
+ sanitizer_platform_limits_posix.h
sanitizer_procmaps.h
sanitizer_quarantine.h
sanitizer_report_decorator.h