summaryrefslogtreecommitdiff
path: root/lib/tsan/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-03-13 09:18:30 +0000
committerAlexey Samsonov <samsonov@google.com>2013-03-13 09:18:30 +0000
commita7e5db966299a50c0e68cf9d35e1130b6c024c94 (patch)
treea4ae33d158c9905625eb07c957013b8d1544ee06 /lib/tsan/CMakeLists.txt
parent10fd3227546d17c7411241a45ebc143b2031c78d (diff)
downloadcompiler-rt-a7e5db966299a50c0e68cf9d35e1130b6c024c94.tar.gz
compiler-rt-a7e5db966299a50c0e68cf9d35e1130b6c024c94.tar.bz2
compiler-rt-a7e5db966299a50c0e68cf9d35e1130b6c024c94.tar.xz
[Sanitizer] Build ASan, TSan and MSan runtimes with -fno-rtti.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@176940 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/tsan/CMakeLists.txt')
-rw-r--r--lib/tsan/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/lib/tsan/CMakeLists.txt b/lib/tsan/CMakeLists.txt
index 34e3a2ea..ef4b6102 100644
--- a/lib/tsan/CMakeLists.txt
+++ b/lib/tsan/CMakeLists.txt
@@ -2,7 +2,9 @@
include_directories(..)
-set(TSAN_CFLAGS ${SANITIZER_COMMON_CFLAGS})
+set(TSAN_CFLAGS
+ ${SANITIZER_COMMON_CFLAGS}
+ -fno-rtti)
# FIXME: Add support for compile flags:
# -Wframe-larger-than=512,
# -Wglobal-constructors,