summaryrefslogtreecommitdiff
path: root/lib/tsan/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2012-09-17 10:02:17 +0000
committerAlexey Samsonov <samsonov@google.com>2012-09-17 10:02:17 +0000
commitf548ef8e3c6bce5a6b2bee48b8f942d2e27ebf92 (patch)
treed6c0f76a734300f390f482f6c20f2c2095b42df1 /lib/tsan/CMakeLists.txt
parent3b339c923b4eefa6a58a349c1a7a1d279612215e (diff)
downloadcompiler-rt-f548ef8e3c6bce5a6b2bee48b8f942d2e27ebf92.tar.gz
compiler-rt-f548ef8e3c6bce5a6b2bee48b8f942d2e27ebf92.tar.bz2
compiler-rt-f548ef8e3c6bce5a6b2bee48b8f942d2e27ebf92.tar.xz
[TSan] move: rtl_tests->tests/rtl unit_tests->tests/unit to make a single root for gtest-based tests. Support running these tests from lit via check-tsan command.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@164022 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/tsan/CMakeLists.txt')
-rw-r--r--lib/tsan/CMakeLists.txt29
1 files changed, 2 insertions, 27 deletions
diff --git a/lib/tsan/CMakeLists.txt b/lib/tsan/CMakeLists.txt
index 39f3ed34..34e3a2ea 100644
--- a/lib/tsan/CMakeLists.txt
+++ b/lib/tsan/CMakeLists.txt
@@ -17,31 +17,6 @@ endif()
add_subdirectory(rtl)
if(LLVM_INCLUDE_TESTS)
- add_custom_target(TsanUnitTests)
- set_target_properties(TsanUnitTests PROPERTIES
- FOLDER "TSan unittests")
-
- function(add_tsan_unittest testname)
- # Build unit tests only on 64-bit Linux.
- if(UNIX AND NOT APPLE
- AND CAN_TARGET_X86_64
- AND CMAKE_SIZEOF_VOID_P EQUAL 8
- AND NOT LLVM_BUILD_32_BITS)
- add_unittest(TsanUnitTests ${testname} ${ARGN})
- # Link with TSan runtime.
- target_link_libraries(${testname} clang_rt.tsan-x86_64)
- # Build tests with PIE and debug info.
- set_property(TARGET ${testname} APPEND_STRING
- PROPERTY COMPILE_FLAGS " -fPIE -g")
- set_property(TARGET ${testname} APPEND_STRING
- PROPERTY LINK_FLAGS " -pie")
- endif()
- endfunction()
-
- include_directories(rtl)
- # There are two groups of unit tests: rtl_tests and unit_tests.
- add_subdirectory(rtl_tests)
- add_subdirectory(unit_tests)
+ add_subdirectory(tests)
endif()
-
-# FIXME: Support TSan runtime tests, unit tests and output tests.
+add_subdirectory(lit_tests)