summaryrefslogtreecommitdiff
path: root/lib/ubsan/lit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2013-10-20 21:29:46 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2013-10-20 21:29:46 +0000
commit9b5f95f5fe1a24be4dfb7436b64cb0e0f8c00535 (patch)
treefbae7a194cba4874ec6393403f354075d5b50914 /lib/ubsan/lit_tests/CMakeLists.txt
parent49d29ed950f9e309a7b755b2a0601ed483ce3ade (diff)
downloadcompiler-rt-9b5f95f5fe1a24be4dfb7436b64cb0e0f8c00535.tar.gz
compiler-rt-9b5f95f5fe1a24be4dfb7436b64cb0e0f8c00535.tar.bz2
compiler-rt-9b5f95f5fe1a24be4dfb7436b64cb0e0f8c00535.tar.xz
Runtime support for the indirect function call checker.
Differential Revision: http://llvm-reviews.chandlerc.com/D1339 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@193060 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ubsan/lit_tests/CMakeLists.txt')
-rw-r--r--lib/ubsan/lit_tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/ubsan/lit_tests/CMakeLists.txt b/lib/ubsan/lit_tests/CMakeLists.txt
index 7e1a13c7..6abc8a01 100644
--- a/lib/ubsan/lit_tests/CMakeLists.txt
+++ b/lib/ubsan/lit_tests/CMakeLists.txt
@@ -8,6 +8,7 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
# working binaries.
set(UBSAN_TEST_DEPS
${SANITIZER_COMMON_LIT_TEST_DEPS}
+ asan
${UBSAN_RUNTIME_LIBRARIES})
set(UBSAN_TEST_PARAMS
ubsan_site_config=${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg